PHP Magic Quotes officially discontinued.

Magic Quotes (which is a feature of PHP, not Apache) is no longer considered good practice, as it introduces some security problems. This feature is deprecated in PHP 5.3, and removed entirely from PHP 5.4 and later. For versions of PHP that do support it, it can only be enabled or disabled at the system level, not for individual users.

Here is the official documentation.

The Wikipedia entry includes a discussion of the problems with Magic Quotes.